Catégorie MCP

Outils développeur

Serveurs MCP pour le développement logiciel, le code, les tests, le débogage et les workflows développeur.

2973 serveurs MCP
32 random hex chars
io.github.sadri-dridi/random-hex32
Generates 32-character random hexadecimal strings and provides miscellaneous developer validation utilities.
Public
31 outils 853 ms
8 random hex chars
io.github.sadri-dridi/random-hex8
Generates 8-character random hexadecimal strings and provides miscellaneous developer validation utilities.
Public
31 outils 581 ms
Range bytes start-end shape, value discarded
io.github.sadri-dridi/range-bytes
Validates HTTP byte-range expressions and provides miscellaneous URL, request, and data-shape utilities.
Public
31 outils 623 ms
Range header shape
io.github.sadri-dridi/range-ok
Validates HTTP Range header syntax and provides miscellaneous URL, request, and data-shape utilities.
Public
31 outils 630 ms
a/b ratio shape, numbers discarded
io.github.sadri-dridi/ratio-ok
Validates a/b ratio syntax and provides miscellaneous arithmetic, URL, and request-shape utilities.
Public
31 outils 320 ms
Rata Die day band
io.github.sadri-dridi/rd-n
Provides Rata Die calendar day-band calculations along with general date, time, and developer utilities.
Public
31 outils 755 ms
Rata Die integer band
io.github.sadri-dridi/rdn-ok
Validates or calculates Rata Die integer ranges and provides general date, time, and developer utilities.
Public
31 outils 187 ms
X-Real-IP IPv4/IPv6 shape, value discarded
io.github.sadri-dridi/real-ip
Validates X-Real-IP IPv4 and IPv6 value shapes without retaining the supplied address.
Public
31 outils 688 ms
Redirect hop count band 0-5
io.github.sadri-dridi/redirect-hop-ok
Checks redirect hop counts within a defined range and provides miscellaneous URL and HTTP inspection utilities.
Public
31 outils 898 ms
Redis URL Shape
io.github.sadri-dridi/redis-url-shape
Validates Redis URL syntax while discarding credentials, with additional URL, HTTP, and data-shape utilities.
Public
31 outils 603 ms
Referrer-Policy token, value discarded
io.github.sadri-dridi/referrer-ok
Validates Referrer-Policy tokens and provides miscellaneous HTTP, URL, and developer validation utilities.
Public
31 outils 660 ms
Refresh seconds;url shape, value discarded
io.github.sadri-dridi/refresh-ok
Validates refresh-header seconds and URL syntax, with additional HTTP, URL, and data-shape utilities.
Public
31 outils 663 ms
Regex compile check, pattern discarded
io.github.sadri-dridi/regex-ok
Checks whether regular-expression patterns compile and provides miscellaneous developer validation utilities.
Public
31 outils 672 ms
Reiwa year from UTC
io.github.sadri-dridi/reiwa-yr
Calculates the Japanese Reiwa year from UTC and provides general date, time, and developer utilities.
Public
31 outils 139 ms
yesterday/today/tomorrow from a UTC date
io.github.sadri-dridi/relative-day-utc
Determines whether a UTC date is yesterday, today, or tomorrow and provides general date and developer utilities.
Public
31 outils 335 ms
Report-To group count, body discarded
io.github.sadri-dridi/report-to
Provides small HTTP, URL, protocol, time, weather, and validation utilities, including Report-To group counting.
Public
31 outils 697 ms
requirements.txt name count, versions discarded
io.github.sadri-dridi/requirements-ok
Counts package names in requirements.txt-style input while discarding version values.
Public
31 outils 381 ms
resolv.conf nameserver count, body discarded
io.github.sadri-dridi/resolv-ok
Counts nameserver entries in resolv.conf-style input and provides related URL and HTTP utilities.
Public
31 outils 365 ms
Retry-After integer-or-date, value discarded
io.github.sadri-dridi/retry-ok
Classifies Retry-After values as integer or date while discarding the value.
Public
31 outils 357 ms
Whether an HTTP status is retryable
io.github.sadri-dridi/retry-status-hint
Determines whether an HTTP status code is retryable.
Public
31 outils 298 ms
encoded-word charset token, input discarded
io.github.sadri-dridi/rfc2047-ok
Checks the charset token of RFC 2047 encoded-word input.
Public
31 outils 299 ms
RFC 3339 UTC stamp
io.github.sadri-dridi/rfc3339-now
Generates a current UTC timestamp formatted according to RFC 3339.
Public
31 outils 452 ms
RFC 3986 unreserved charset, input discarded
io.github.sadri-dridi/rfc3986-ok
Checks whether input uses RFC 3986 unreserved characters.
Public
31 outils 660 ms
RFC errata id shape, value discarded
io.github.sadri-dridi/rfc-errata-ok
Checks the shape of an RFC errata identifier.
Public
31 outils 523 ms
RFC number shape
io.github.sadri-dridi/rfc-number-ok
Checks the format of an RFC number.
Public
31 outils 445 ms
RFC section number shape
io.github.sadri-dridi/rfc-section-ok
Checks the format of an RFC section number.
Public
31 outils 447 ms
HTTP status class 1xx-5xx
io.github.sadri-dridi/rfc-status
Classifies an HTTP status code into the 1xx through 5xx status classes.
Public
31 outils 470 ms
RIPEMD-160 hex length, input discarded
io.github.sadri-dridi/ripemd160
Checks the expected hexadecimal length associated with RIPEMD-160 output.
Public
31 outils 738 ms
RIPEMD hex length, input discarded
io.github.sadri-dridi/ripemd-len
Checks the expected hexadecimal length of RIPEMD hash output.
Public
31 outils 758 ms
RIS tag count, body discarded
io.github.sadri-dridi/ris-ok
Counts tags in RIS bibliographic citation input.
Public
31 outils 168 ms